Nothing provides Libcrypto.so.1.0.0(Openssl.1.0.0) ....

i2gamei2game New or Quiet Member
Hi there,
I got the file missing While I am installing postgresql on SLES 12.

After I followed the steps of URL:
https://zypp.postgresql.org/howtozypp.php
I successfully registered the evaluation version of SLES 12, and successfully added respository and registered the below two
SUSEConnect -p PackageHub/12/x86_64
SUSEConnect -p sle-sdk/12/x86_64

When I started installing postgresql by "zypper install postgresql12-server", it popped the error: Problem: nothing provides Libcrypto.so.1.0.0(Openssl.1.0.0). .....
===
# zypper install postgresql12-server
Refreshing service 'SUSE_Linux_Enterprise_Software_Development_Kit_12_x86_64'.
Refreshing service 'SUSE_Package_Hub_12_x86_64'.
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides libcrypto.so.1.0.0(OPENSSL_1.0.0)(64bit) needed by postgresql12-server-12.2-1PGDG.sles12.x86_64
Solution 1: do not install postgresql12-server-12.2-1PGDG.sles12.x86_64
Solution 2: break postgresql12-server-12.2-1PGDG.sles12.x86_64 by ignoring some of its dependencies
====


Does my Suse miss the OPENSSL 1.0? Where can I install the old OPENSSL 1.0?

i2game

Comments

  • Hi i2game,

    did you found any solution for this?
    When adding the postgres11 repository, the installation of the postgres11-server is working well. But, when trying to install additional package (like postgressql11, for getting some tools) I receive the same error as you did.
    Best regards
    chobbs

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi and welcome to the Forum @choobs :)
    It this from SUSE Package Hub and SLES 12 (which SP?)?

Sign In or Register to comment.